AboutSummaryRefsLogTreeCommitDiffStats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6a01ec9..2b2f92e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -181,6 +181,22 @@ install-exec-hook:
chmod u+s $(DESTDIR)$(bindir)/$${tcrontab}
endif
+installcheck-local:
+## Check that only expected programs are installed and configured
+ tmcron=`echo mcron$(EXEEXT) | sed '$(transform_exe)'`; \
+ test -e $(DESTDIR)$(bindir)/$${tmcron}
+if MULTI_USER
+ tcrontab=`echo crontab$(EXEEXT) | sed '$(transform_exe)'`; \
+ test -u $(DESTDIR)$(bindir)/$${tcrontab}
+ tcron=`echo cron$(EXEEXT) | sed '$(transform_exe)'`; \
+ test -e $(DESTDIR)$(sbindir)/$${tcron}
+else !MULTI_USER
+ tcrontab=`echo crontab$(EXEEXT) | sed '$(transform_exe)'`; \
+ test ! -u $(DESTDIR)$(bindir)/$${tcrontab}
+ tcron=`echo cron$(EXEEXT) | sed '$(transform_exe)'`; \
+ test ! -f $(DESTDIR)$(sbindir)/$${tcron}
+endif !MULTI_USER
+
## --------------- ##
## Documentation. ##
## --------------- ##