AboutSummaryRefsLogTreeCommitDiffStats
path: root/configure.ac
diff options
context:
space:
mode:
authorDale Mellor <mcron-lsfnyl@rdmp.org>2023-03-18 14:18:17 +0000
committerDale Mellor <mcron-lsfnyl@rdmp.org>2023-03-18 14:18:17 +0000
commit0fe4d2cc9544d24ecc3e74a2d92433e01b9e25c6 (patch)
tree2cf2ffe793211a8c48ff86a9db57b156f2cddd88 /configure.ac
parentfd19e63490e30fb5ae4cc159f72b8f40952ceb9d (diff)
parent4727c770c2a723d46b4162cff21ab8f0b75c3998 (diff)
downloadmcron-0fe4d2cc9544d24ecc3e74a2d92433e01b9e25c6.tar.gz
mcron-0fe4d2cc9544d24ecc3e74a2d92433e01b9e25c6.tar.bz2
mcron-0fe4d2cc9544d24ecc3e74a2d92433e01b9e25c6.zip
Merge system-wide Vixie cron updates.
I don't believe that anyone should be running system-wide cron processes these days (the attack surface is rather large), but should use separate per-user or per-service mcron daemon processes. But mcron is advertised as a drop-in Vixie replacement, so we should do what we can to make it safe in this use case. I've performed a basic vetting of the changes against vandalism, but haven't verified the correctness of the code or done any checking; the changes are being accepted on the basis that almost anything is an improvement on what currently exists.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a732f19..784a5a1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,6 +65,14 @@ AC_ARG_ENABLE([multi-user],
[Don't Install legacy cron and crontab programs])],
[enable_multi_user="$enableval"],
[enable_multi_user="yes"])
+
+dnl Not possible to run this conditionally?
+AC_PROG_CC
+dnl AS_IF([test "x$enable_multi_user" = xyes],
+dnl [# Need a C compiler to compile setuid wrapper
+dnl AC_PROG_CC]
+dnl fi
+
AM_CONDITIONAL([MULTI_USER], [test "x$enable_multi_user" = xyes])
# Configure the various files that mcron uses at runtime.
@@ -127,5 +135,5 @@ AC_CONFIG_FILES([pre-inst-env:build-aux/pre-inst-env.in],
[chmod +x pre-inst-env])
AC_CONFIG_FILES([doc/config.texi
Makefile
- src/mcron/config.scm])
+ src/mcron/config.scm.in])
AC_OUTPUT