AboutSummaryRefsLogTreeCommitDiffStats
path: root/build-aux/guix.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2018-10-01 14:07:48 +0800
committerMathieu Lirzin <mthl@gnu.org>2018-10-07 12:22:53 +0200
commit7228d3048a89facee77689e390d5f5c091c57d73 (patch)
tree15cae4dffc52f760eea3be9f9a04de2fc19473a8 /build-aux/guix.scm
parentefa2f51ae329c07c54dd9d90615c96fb4045f4c8 (diff)
downloadmcron-7228d3048a89facee77689e390d5f5c091c57d73.tar.gz
mcron-7228d3048a89facee77689e390d5f5c091c57d73.tar.bz2
mcron-7228d3048a89facee77689e390d5f5c091c57d73.zip
build: Add '--with-sendmail' configure option
This allows users to configure the Mail Transfert Agent (MTA) of their choice. * configure.ac: Add '--with-sendmail' option. (SENDMAIL): Default to 'sendmail -t'. * NEWS: Announce it. * src/mcron/redirect.scm (with-mail-out): Assume the MTA is reading the message for recipients. * build-aux/guix.scm: Remove 'which' from the native-inputs.
Diffstat (limited to 'build-aux/guix.scm')
-rw-r--r--build-aux/guix.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/build-aux/guix.scm b/build-aux/guix.scm
index d90e0be..24927ad 100644
--- a/build-aux/guix.scm
+++ b/build-aux/guix.scm
@@ -1,5 +1,6 @@
;;;; guix.scm -- Guix package definition
;;; Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
+;;; Copyright © 2018 宋文武 <iyzsong@member.fsf.org>
;;;
;;; This file is part of GNU Mcron.
;;;
@@ -62,5 +63,4 @@
("automake" ,(specification->package "automake"))
("help2man" ,(specification->package "help2man"))
("pkg-config" ,(specification->package "pkg-config"))
- ("texinfo" ,(specification->package "texinfo"))
- ("which" ,(specification->package "which")))))
+ ("texinfo" ,(specification->package "texinfo")))))