AboutSummaryRefsLogTreeCommitDiffStats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2016-05-07 11:09:44 +0200
committerMathieu Lirzin <mthl@gnu.org>2016-05-07 23:38:53 +0200
commit995bc9ca6ebf6880d7e7e6f3d1baa2941758fc47 (patch)
tree1f12ba3e4218d91a8736df5a5fa6eb82ffe39181 /Makefile.am
parentbb8703b679509fe3b842f9f24f6871b3c2889916 (diff)
downloadmcron-995bc9ca6ebf6880d7e7e6f3d1baa2941758fc47.tar.gz
mcron-995bc9ca6ebf6880d7e7e6f3d1baa2941758fc47.tar.bz2
mcron-995bc9ca6ebf6880d7e7e6f3d1baa2941758fc47.zip
all: Rename 'scm' directory to 'src'.
* scm/mcron/config.scm.in: Rename to ... * src/mcron/config.scm.in: ... this. * scm/mcron/crontab.scm: Rename to ... * src/mcron/crontab.scm: ... this. * scm/mcron/environment.scm: Rename to ... * src/mcron/environment.scm: ... this. * scm/mcron/job-specifier.scm: Rename to ... * src/mcron/job-specifier.scm: ... this. * scm/mcron/main.scm: Rename to ... * src/mcron/main.scm: ... this. * scm/mcron/mcron-core.scm: Rename to ... * src/mcron/mcron-core.scm: ... this. * scm/mcron/redirect.scm: Rename to ... * src/mcron/redirect.scm: ... this. * scm/mcron/vixie-specification.scm: Rename to ... * src/mcron/vixie-specification.scm: ... this. * scm/mcron/vixie-time.scm: Rename to ... * src/mcron/vixie-time.scm: ... this. * mcron.c: Rename to ... * src/mcron.c: ... this. * Makefile.am: Adapt to them. * build-aux/pre-inst-env.in: Likewise. * configure.ac (AC_CONFIG_FILES): Likewise. (AC_CONFIG_HEADER): Set to 'src/config.h'. * .gitignore: Update.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am30
1 files changed, 15 insertions, 15 deletions
diff --git a/Makefile.am b/Makefile.am
index 4f11c0f..1b5317c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,26 +17,26 @@
# along with this program. If not, see <http://www.gnu.org/licenses/>.
bin_PROGRAMS = mcron
-mcron_SOURCES = mcron.c
+mcron_SOURCES = src/mcron.c
mcron_CFLAGS = @GUILE_CFLAGS@
mcron_DEPENDENCIES = $(GOBJECTS) # Build Guile modules before linking.
mcron_LDADD = @GUILE_LIBS@
MODULES = \
- scm/mcron/environment.scm \
- scm/mcron/job-specifier.scm \
- scm/mcron/main.scm \
- scm/mcron/redirect.scm \
- scm/mcron/vixie-specification.scm \
- scm/mcron/vixie-time.scm
+ src/mcron/environment.scm \
+ src/mcron/job-specifier.scm \
+ src/mcron/main.scm \
+ src/mcron/redirect.scm \
+ src/mcron/vixie-specification.scm \
+ src/mcron/vixie-time.scm
GEN_MODULES = \
- scm/mcron/config.scm \
- scm/mcron/core.scm
+ src/mcron/config.scm \
+ src/mcron/core.scm
CP = @CP@
# XXX: Prevent the 'configure' script to delete the 'core.*' files.
-scm/mcron/core.scm: scm/mcron/mcron-core.scm
+src/mcron/core.scm: src/mcron/mcron-core.scm
$(CP) $< $@
GOBJECTS = \
@@ -49,8 +49,8 @@ mcronmodule_DATA = \
dist_mcronmodule_DATA = \
$(MODULES) \
- scm/mcron/crontab.scm \
- scm/mcron/mcron-core.scm
+ src/mcron/crontab.scm \
+ src/mcron/mcron-core.scm
# Unset 'GUILE_LOAD_COMPILED_PATH' altogether while compiling. Otherwise, if
# $GUILE_LOAD_COMPILED_PATH contains $(mcronmoduledir), we may find .go files
@@ -67,8 +67,8 @@ dist_mcronmodule_DATA = \
export GUILE_AUTO_COMPILE=0 ; unset GUILE_LOAD_COMPILED_PATH ; \
LC_ALL=C \
$(top_builddir)/pre-inst-env $(GUILD) compile \
- --load-path="$(top_builddir)/scm" \
- --load-path="$(top_srcdir)/scm" \
+ --load-path="$(top_builddir)/src" \
+ --load-path="$(top_srcdir)/src" \
--warn=format --warn=unbound-variable --warn=arity-mismatch \
--target="$(host)" --output="$@" "$<"
@@ -134,7 +134,7 @@ TEXI2DVI = texi2dvi -I doc
# Not part of formal package building, but a rule for manual use to get the
# elemental man page. Will only work once the mcron program is installed.
-doc/mcron.1: mcron.c
+doc/mcron.1: src/mcron.c
-$(AM_V_HELP2MAN)$(MKDIR_P) `dirname "$@"` ; \
$(top_builddir)/pre-inst-env $(HELP2MAN) \
-n 'a program to run tasks at regular (or not) intervals' \