AboutSummaryRefsLogTreeCommitDiffStats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c2d42b4..b6c325b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -116,6 +116,7 @@ uninstall-hook:
EXTRA_DIST = BUGS
CLEANFILES = $(GOBJECTS)
+DISTCLEANFILES = $(GEN_MODULES)
## --------------- ##
## Documentation. ##
@@ -123,8 +124,13 @@ CLEANFILES = $(GOBJECTS)
info_TEXINFOS = doc/mcron.texi
doc_mcron_TEXINFOS = doc/fdl.texi
+nodist_doc_mcron_TEXINFOS = doc/config.texi
dist_man_MANS = doc/mcron.1
+# XXX: Allow the inclusion of 'doc/fdl.texi' and 'doc/config.texi' inside
+# 'doc/mcron.texi' for 'dvi' and 'pdf' targets.
+TEXI2DVI = texi2dvi -I doc
+
# Not part of formal package building, but a rule for manual use to get the
# elemental man page. Will only work once the mcron program is installed.
doc/mcron.1: mcron.c