SummaryRefsLogTreeCommitDiffStats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 1e953c6..96b67c1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -172,12 +172,13 @@ EXTRA_DIST = \
## Installation. ##
## -------------- ##
-#full program prefix
-fpp = $(DESTDIR)$(bindir)/@real_program_prefix@
+# Sed command for Transforming program names.
+transform_exe = s/$(EXEEXT)$$//;$(transform);s/$$/$(EXEEXT)/
if MULTI_USER
install-exec-hook:
- chmod u+s $(fpp)crontab$(EXEEXT)
+ tcrontab=`echo crontab$(EXEEXT) | sed '$(transform_exe)'`; \
+ chmod u+s $(DESTDIR)$(bindir)/$${tcrontab}
endif
## --------------- ##