SummaryRefsLogTreeCommitDiffStats
path: root/configure.ac
diff options
context:
space:
mode:
authorulfvonbelow <striness@tilde.club>2023-02-02 19:29:52 +0000
committerDale Mellor <mcron-lsfnyl@rdmp.org>2023-03-18 14:00:26 +0000
commit4727c770c2a723d46b4162cff21ab8f0b75c3998 (patch)
tree5cdd3a6c110d60d96892032b05edb60f0a77271c /configure.ac
parent2ff4d0f44ec21332d13de8d8ab8c39c77450ff7d (diff)
downloadmcron-4727c770c2a723d46b4162cff21ab8f0b75c3998.tar.gz
mcron-4727c770c2a723d46b4162cff21ab8f0b75c3998.tar.bz2
mcron-4727c770c2a723d46b4162cff21ab8f0b75c3998.zip
crontab-access: replace with wrapper, rename to crontab-access-real.
The wrapper has two purposes: 1. Not being a script, thereby eliminating the issues with setuid scripts. 2. Purging the environment. crontab-access-real has no need for any environment variables to do its work, so to prevent tampering with dynamic linker, libc, or guile, we may as well just unset them all. This wrapper does introduce a requirement for a C compiler. Ideally it would be conditional based on whether the wrapper is even going to be built, but autoconf doesn't like that one bit. Someone with more experience with autotools should sort that out. In the meantime I guess anyone wanting to build without a C compiler being present is going to have to edit configure.ac and re-run bootstrap. * src/crontab-access.in: renamed to src/crontab-access-real.in * src/crontab-access.c.in: new file, wrapper for crontab-access-real. * Makefile.am: inform about crontab-access.c.in and name change to crontab-access-real. Put crontab-access-real in libexecdir.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7ea532f..b79e3c3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,6 +65,14 @@ AC_ARG_ENABLE([multi-user],
[Don't Install legacy cron and crontab programs])],
[enable_multi_user="$enableval"],
[enable_multi_user="yes"])
+
+dnl Not possible to run this conditionally?
+AC_PROG_CC
+dnl AS_IF([test "x$enable_multi_user" = xyes],
+dnl [# Need a C compiler to compile setuid wrapper
+dnl AC_PROG_CC]
+dnl fi
+
AM_CONDITIONAL([MULTI_USER], [test "x$enable_multi_user" = xyes])
# Configure the various files that mcron uses at runtime.