SummaryRefsLogTreeCommitDiffStats
path: root/configure.ac
diff options
context:
space:
mode:
authordale_mellor <dale_mellor>2003-07-04 08:09:04 +0000
committerdale_mellor <dale_mellor>2003-07-04 08:09:04 +0000
commit3725aedd02d9b24c1239610066dd62387ef4d5a9 (patch)
treefce5dd0b6d658fd897bb91a823c983ceb15b59ba /configure.ac
downloadmcron-3725aedd02d9b24c1239610066dd62387ef4d5a9.tar.gz
mcron-3725aedd02d9b24c1239610066dd62387ef4d5a9.tar.bz2
mcron-3725aedd02d9b24c1239610066dd62387ef4d5a9.zip
Initial version. Production quality, fully complete source but contains known bugs (lots!)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac82
1 files changed, 82 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..f56b111
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,82 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.57)
+AC_INIT(mcron, 0.99.1, dale_mellor@users.sourceforge.net)
+AM_INIT_AUTOMAKE
+
+
+AC_MSG_CHECKING([whether debugging is requested])
+AC_ARG_ENABLE(debug,
+ AC_HELP_STRING([--enable-debug],
+ [enable debugging and traceback on error]),
+ CONFIG_DEBUG=$enableval,
+ CONFIG_DEBUG=no)
+AC_MSG_RESULT($CONFIG_DEBUG)
+if test "$CONFIG_DEBUG" = "no"; then
+ CONFIG_DEBUG="#f"
+else
+ CONFIG_DEBUG="#t"
+fi
+AC_SUBST(CONFIG_DEBUG)
+
+
+AC_PROG_CC
+GUILE_PROGS
+GUILE_FLAGS
+
+# Checks for programs.
+ # AC_CHECK_PROG(CHMOD, chmod, chmod)
+AC_CHECK_PROGS(CHMOD, chmod)
+if test "x$ac_cv_prog_CHMOD" = "x"; then
+ AC_MSG_ERROR(chmod not found)
+fi
+AC_CHECK_PROGS(ED, ed)
+if test "x$ac_cv_prog_ED" = "x"; then
+ AC_MSG_ERROR(ed not found)
+fi
+AC_CHECK_PROGS(CAT, cat)
+if test "x$ac_cv_prog_CAT" = "x"; then
+ AC_MSG_ERROR(cat not found)
+fi
+AC_CHECK_PROGS(WHICH, which)
+if test "x$ac_cv_prog_WHICH" = "x"; then
+ AC_MSG_ERROR(which not found)
+fi
+
+# Now find a sendmail or equivalent.
+
+AC_CHECK_PROGS(SENDMAIL, sendmail)
+if test "x$ac_cv_prog_SENDMAIL" != "x"; then
+ AC_MSG_CHECKING(sendmail path and arguments)
+ ac_cv_prog_SENDMAIL="`$ac_cv_prog_WHICH sendmail` -FCronDaemon -odi -oem "
+dnl -or0s"
+ AC_MSG_RESULT($ac_cv_prog_SENDMAIL)
+
+else
+ AC_CHECK_PROGS(SENDMAIL, mail)
+ if test "x$ac_cv_prog_SENDMAIL" != "x"; then
+ AC_MSG_CHECKING(mail path)
+ ac_cv_prog_SENDMAIL="`$ac_cv_prog_WHICH sendmail` -d "
+ AC_MSG_RESULT($ac_cv_prog_SENDMAIL)
+ else
+ AC_MSG_RESULT(No mail program found)
+ fi
+fi
+SENDMAIL=$ac_cv_prog_SENDMAIL
+
+
+# Checks for libraries.
+
+# Checks for header files.
+
+# Checks for typedefs, structures, and compiler characteristics.
+
+# Checks for library functions.
+
+real_program_prefix=`echo $program_prefix | sed s/NONE//`
+AC_SUBST(real_program_prefix)
+
+
+AC_CONFIG_FILES(makefile config.scm)
+AC_OUTPUT