AboutSummaryRefsLogTreeCommitDiffStats
path: root/configure.ac
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2017-02-22 15:49:18 +0100
committerMathieu Lirzin <mthl@gnu.org>2017-09-28 13:19:28 +0200
commit245f1ae3380330e31bfdcb7f4fe17698a2fa021d (patch)
treea2859f5b0545a54d7949cf0ef7f2219901faed25 /configure.ac
parentf284b524465afcac4ff248ae5aecfefa7348d05f (diff)
downloadmcron-245f1ae3380330e31bfdcb7f4fe17698a2fa021d.tar.gz
mcron-245f1ae3380330e31bfdcb7f4fe17698a2fa021d.tar.bz2
mcron-245f1ae3380330e31bfdcb7f4fe17698a2fa021d.zip
build: Replace "--enable-no-vixie-clobber" with "--disable-multi-user".
* configure.ac: Define "--disable-multi-user" option instead of "--enable-no-vixie-clobber". * Makefile.am (install-exec-hook) [MULTI_USER]: Only set crontab setuid bit. (bin_PROGRAMS): Keep only 'mcron' by default. (bin_PROGRAMS) [MULTI_USER]: Add 'crontab' (sbin_PROGRAMS) [MULTI_USER]: Add 'cron'. (noinst_PROGRAMS) [!MULTI_USER]: Add 'cron' and 'crontab'. (dist_man_MANS): Move 'crontab.1' and 'cron.8' ... (extra_mans): here. New variable. (dist_man_MANS) [MULTI_USER]: Add it. (all-local) [!MULTI_USER]: New target. Depend on it. (EXTRA_DIST) [!MULTI_USER]: Distribute it. (MAINTAINERCLEANFILES): Clean it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 6 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 8c5fc08..363a74f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -104,18 +104,12 @@ else
fi
SENDMAIL=$ac_cv_prog_SENDMAIL
-
-# Find out if we are avoiding Vixie.
-
-AC_MSG_CHECKING([whether to avoid clobbering a Vixie installation])
-AC_ARG_ENABLE(no-vixie-clobber,
- AC_HELP_STRING([--enable-no-vixie-clobber],
- [do not install with program names that would override a legacy cron installation]),
- NO_VIXIE_CLOBBER=$enableval,
- NO_VIXIE_CLOBBER=[no])
-AC_MSG_RESULT($NO_VIXIE_CLOBBER)
-AC_SUBST(NO_VIXIE_CLOBBER)
-
+AC_ARG_ENABLE([multi-user],
+ [AS_HELP_STRING([--disable-multi-user],
+ [Don't Install legacy cron and crontab programs])],
+ [enable_multi_user="$enableval"],
+ [enable_multi_user="yes"])
+AM_CONDITIONAL([MULTI_USER], [test "x$enable_multi_user" != xyes])
# Configure the various files that mcron uses at runtime.