AboutSummaryRefsLogTreeCommitDiffStats
path: root/configure.ac
diff options
context:
space:
mode:
authorDale Mellor <dale@rdmp.org>2010-06-13 03:49:39 +0100
committerDale Mellor <dale@rdmp.org>2010-06-13 03:49:39 +0100
commit323033546da8d2b00ef993223cc83b003e183aa0 (patch)
treed4824920b115643e2547eb3b1364e22e5436c2a7 /configure.ac
parentf76377aa373b9553836e84402015d4da6685a184 (diff)
downloadmcron-323033546da8d2b00ef993223cc83b003e183aa0.tar.gz
mcron-323033546da8d2b00ef993223cc83b003e183aa0.tar.bz2
mcron-323033546da8d2b00ef993223cc83b003e183aa0.zip
Added --enable-no-vixie-clobber to configure.ac.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3253535..aef53f5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -105,6 +105,18 @@ fi
SENDMAIL=$ac_cv_prog_SENDMAIL
+# Find out if we are avoiding Vixie.
+
+AC_MSG_CHECKING([whether to avoid clobbering a Vixie installation])
+AC_ARG_ENABLE(no-vixie-clobber,
+ AC_HELP_STRING([--enable-no-vixie-clobber],
+ [do not install with program names that would override a legacy cron installation]),
+ NO_VIXIE_CLOBBER=$enableval,
+ NO_VIXIE_CLOBBER=[no])
+AC_MSG_RESULT($NO_VIXIE_CLOBBER)
+AC_SUBST(NO_VIXIE_CLOBBER)
+
+
# Configure the various files that mcron uses at runtime.
AC_MSG_CHECKING([which spool directory to use])