AboutSummaryRefsLogTreeCommitDiffStats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2016-05-10 01:06:10 +0200
committerMathieu Lirzin <mthl@gnu.org>2016-12-01 00:15:55 +0100
commit9d173e23bc0bf39c1114f2ac6fc6e5c1e56dd55f (patch)
tree3a6a3d719e4da61b3943f27f8c5c08c31eab2f5a /Makefile.am
parentc9064dde98b2a91be6c9f23c37168c7468fd873f (diff)
downloadmcron-9d173e23bc0bf39c1114f2ac6fc6e5c1e56dd55f.tar.gz
mcron-9d173e23bc0bf39c1114f2ac6fc6e5c1e56dd55f.tar.bz2
mcron-9d173e23bc0bf39c1114f2ac6fc6e5c1e56dd55f.zip
job-specifier: range: Add tests.
* build-aux/test-driver.scm: New script. * configure.ac (AC_REQUIRE_AUX_FILE): Add it. * tests/job-specifier.scm: New test. * Makefile.am (TEST_EXTENSIONS, AM_TESTS_ENVIRONMENT, SCM_LOG_DRIVER) (TESTS): New variables. (EXTRA_DIST): Update. * .gitignore: Likewise.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ec98ef3..020aac6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -61,6 +61,15 @@ modules = \
$(dist_mcronscript_DATA) \
src/mcron/config.scm
+TEST_EXTENSIONS = .scm
+AM_TESTS_ENVIRONMENT = env GUILE_AUTO_COMPILE='0'
+
+SCM_LOG_DRIVER = \
+ $(builddir)/pre-inst-env $(GUILE) \
+ $(srcdir)/build-aux/test-driver.scm
+
+TESTS = tests/job-specifier.scm
+
# Unset 'GUILE_LOAD_COMPILED_PATH' altogether while compiling. Otherwise, if
# $GUILE_LOAD_COMPILED_PATH contains $(mcronmoduledir), we may find .go files
# in there that are newer than the local .scm files (for instance because the
@@ -124,7 +133,7 @@ uninstall-hook:
rm -f $(fpp){cron,crontab}$(EXEEXT); \
fi
-EXTRA_DIST = BUGS
+EXTRA_DIST = BUGS $(TESTS)
DISTCLEANFILES = src/config.scm
CLEANFILES = \
$(modules:%.scm=%.go) \