AboutSummaryRefsLogTreeCommitDiffStats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2017-01-13 17:13:48 +0100
committerMathieu Lirzin <mthl@gnu.org>2017-09-27 23:21:54 +0200
commit57b9294277f2f92e1478ff0d478e483d0a584347 (patch)
tree5a66240e6b854d798012aa340229a41abe201fad /Makefile.am
parentd72716ce16e8326f14ff7ae9ca41af5315e94ae4 (diff)
downloadmcron-57b9294277f2f92e1478ff0d478e483d0a584347.tar.gz
mcron-57b9294277f2f92e1478ff0d478e483d0a584347.tar.bz2
mcron-57b9294277f2f92e1478ff0d478e483d0a584347.zip
wrapper: Avoid 'scm_c_eval_string' usage.
* src/wrapper.c (wrap_env_path): New function. (main): Use it. (inner_main): Let 'wrap_env_path' set the environment variables. Don't use 'scm_c_eval_string' when calling 'main' procedure. * Makefile.am (AM_CPPFLAGS): Define _GNU_SOURCE for 'asprintf'.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 45bb941..a9b2bf7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,6 @@
## Process this file with automake to produce Makefile.in.
# Copyright © 2003 Dale Mellor <dale_mellor@users.sourceforge.net>
-# Copyright © 2015, 2016 Mathieu Lirzin <mthl@gnu.org>
+# Copyright © 2015, 2016, 2017 Mathieu Lirzin <mthl@gnu.org>
#
# This file is part of GNU Mcron.
#
@@ -20,7 +20,7 @@
bin_PROGRAMS = bin/mcron bin/crontab
sbin_PROGRAMS = bin/cron
-AM_CPPFLAGS = -DPACKAGE_LOAD_PATH=\"$(moduledir)\"
+AM_CPPFLAGS = -DPACKAGE_LOAD_PATH=\"$(moduledir)\" -D_GNU_SOURCE
AM_CFLAGS = @GUILE_CFLAGS@
LDADD = @GUILE_LIBS@