SummaryRefsLogTreeCommitDiffStats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2018-03-20 00:57:02 +0100
committerMathieu Lirzin <mthl@gnu.org>2018-03-20 02:17:11 +0100
commit624ceb44809f2be891f0af82df1d917d4a5aa9c1 (patch)
tree8b6836e90650104ccff644fd374f3e0b665715d9 /Makefile.am
parentdd9d6a6b06f3ec249757c728dc1568b2e4efbd3f (diff)
downloadmcron-624ceb44809f2be891f0af82df1d917d4a5aa9c1.tar.gz
mcron-624ceb44809f2be891f0af82df1d917d4a5aa9c1.tar.bz2
mcron-624ceb44809f2be891f0af82df1d917d4a5aa9c1.zip
build: Properly set Guile load paths in programs
This fixes an issue where the installed Guile load paths were set by the undefined 'moduledir' Make macro. * Makefile.am (AM_CPPFLAGS): Define PACKAGE_LOAD_PATH with 'guilesitedir' macro and PACKAGE_LOAD_COMPILED_PATH with 'guilesitegodir'. * NEWS: Update.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 96b67c1..6a01ec9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -31,8 +31,8 @@ noinst_PROGRAMS = bin/cron bin/crontab
endif
AM_CPPFLAGS = \
- -DPACKAGE_LOAD_PATH=\"$(moduledir)\" \
- -DPACKAGE_LOAD_COMPILED_PATH=\"$(moduledir)\" \
+ -DPACKAGE_LOAD_PATH=\"$(guilesitedir)\" \
+ -DPACKAGE_LOAD_COMPILED_PATH=\"$(guilesitegodir)\" \
-D_GNU_SOURCE
AM_CFLAGS = @GUILE_CFLAGS@