SummaryRefsLogTreeCommitDiffStats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2016-07-17 00:10:35 +0200
committerMathieu Lirzin <mthl@gnu.org>2016-12-01 00:15:56 +0100
commit245413041c1ddee4bb7d752f6f1044750b887df8 (patch)
tree999280db336c070f17d92093d36225c01b05e40f /Makefile.am
parent6a82b53ddd8cb93f60121cb02e1276e089926ad1 (diff)
downloadmcron-245413041c1ddee4bb7d752f6f1044750b887df8.tar.gz
mcron-245413041c1ddee4bb7d752f6f1044750b887df8.tar.bz2
mcron-245413041c1ddee4bb7d752f6f1044750b887df8.zip
build: Define PACKAGE_LOAD_PATH in Makefile.
Previously PACKAGE_LOAD_PATH was set in config header which wasn't correctly expanded due to the presence of ${prefix} in ${moduledir}. Let 'make' handle the expansion. * Makefile.am (AM_CPPFLAGS): New variable. (cron_CPPFLAGS, crontab_CPPFLAGS, mcron_CPPFLAGS): Use it. * configure.ac (PACKAGE_LOAD_PATH): Undefine it. (AC_CONFIG_HEADER): Remove macro. * src/mcron.c: Adapt to it.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index ddb1c26..d01e730 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,19 +19,20 @@
bin_PROGRAMS = mcron crontab
sbin_PROGRAMS = cron
+AM_CPPFLAGS = -DPACKAGE_LOAD_PATH=\"$(moduledir)\"
AM_CFLAGS = @GUILE_CFLAGS@
LDADD = @GUILE_LIBS@
mcron_SOURCES = src/mcron.c
-mcron_CPPFLAGS = -DPROGRAM="\"mcron\""
+mcron_CPPFLAGS = $(AM_CPPFLAGS) -DPROGRAM="\"mcron\""
mcron_DEPENDENCIES = $(modules:%.scm=%.go)
cron_SOURCES = src/mcron.c
-cron_CPPFLAGS = -DPROGRAM="\"cron\""
+cron_CPPFLAGS = $(AM_CPPFLAGS) -DPROGRAM="\"cron\""
cron_DEPENDENCIES = $(modules:%.scm=%.go)
crontab_SOURCES = src/mcron.c
-crontab_CPPFLAGS = -DPROGRAM="\"crontab\""
+crontab_CPPFLAGS = $(AM_CPPFLAGS) -DPROGRAM="\"crontab\""
crontab_DEPENDENCIES = $(modules:%.scm=%.go)
dist_mcronmodule_DATA = \