SummaryRefsLogTreeCommitDiffStats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2016-05-10 21:00:59 +0200
committerMathieu Lirzin <mthl@gnu.org>2016-12-01 00:15:56 +0100
commit10c9f31c6c6dee962e114a0ea494088d8fdb3502 (patch)
tree11e7f058f6c73ea373d7fc81cbcf7170eed7b038 /Makefile.am
parent4a56db16097b06a9e894d5bb0d3997fe8cf0c1eb (diff)
downloadmcron-10c9f31c6c6dee962e114a0ea494088d8fdb3502.tar.gz
mcron-10c9f31c6c6dee962e114a0ea494088d8fdb3502.tar.bz2
mcron-10c9f31c6c6dee962e114a0ea494088d8fdb3502.zip
build: Use Automake warnings.
* configure.ac (AM_INIT_AUTOMAKE): Add more warnings. * Makefile.am (AM_V_GUILEC, AM_V_GUILEC_, AM_V_GUILEC_0): Rename to ... (guilec_verbose, guilec_verbose_, guilec_verbose_0): ... these. Make them more portable. This follows an example from Automake manual.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 305421d..0504a2c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -83,7 +83,7 @@ TESTS = \
# XXX: Use the C locale for when Guile lacks
# <http://git.sv.gnu.org/cgit/guile.git/commit/?h=stable-2.0&id=e2c6bf3866d1186c60bacfbd4fe5037087ee5e3f>.
.scm.go:
- $(AM_V_GUILEC)$(MKDIR_P) `dirname "$@"` ; \
+ $(guilec_verbose)$(MKDIR_P) `dirname "$@"` ; \
export GUILE_AUTO_COMPILE=0 ; unset GUILE_LOAD_COMPILED_PATH ; \
LC_ALL=C \
$(top_builddir)/pre-inst-env $(GUILD) compile \
@@ -183,6 +183,6 @@ $(srcdir)/doc/cron.8: src/mcron/scripts/cron.scm cron
## Silent rules. ##
## -------------- ##
-AM_V_GUILEC = $(AM_V_GUILEC_$(V))
-AM_V_GUILEC_ = $(AM_V_GUILEC_$(AM_DEFAULT_VERBOSITY))
-AM_V_GUILEC_0 = @echo " GUILEC " $@;
+guilec_verbose = $(guilec_verbose_@AM_V@)
+guilec_verbose_ = $(guilec_verbose_@AM_DEFAULT_V@)
+guilec_verbose_0 = @echo " GUILEC " $@;