SummaryRefsLogTreeCommitDiffStats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2017-04-25 00:29:32 +0200
committerMathieu Lirzin <mthl@gnu.org>2017-09-28 15:57:21 +0200
commitc01106387f6d0866ef6fd4801473984cc642e60b (patch)
tree5e526b3efa61472cceecc01d6888da9cd52173e8 /Makefile.am
parent9b52c0d4544b2ed0fba156f87b75632c75b2084c (diff)
downloadmcron-c01106387f6d0866ef6fd4801473984cc642e60b.tar.gz
mcron-c01106387f6d0866ef6fd4801473984cc642e60b.tar.bz2
mcron-c01106387f6d0866ef6fd4801473984cc642e60b.zip
Replace generic C wrapper with individual programs
* src/wrapper.c: Delete. * src/crontab.c: New file. * src/mcron.c: Likewise. * src/cron.c: Likewise. * configure.ac: Adapt 'AC_CONFIG_DIR' to use "src/mcron.c". * Makefile.am (bin_crontab_SOURCES, bin_cron_SOURCES) (bin_mcron_SOURCES): Use new files. (bin_cron_CPPFLAGS, bin_mcron_CPPFLAGS, bin_crontab_CPPFLAGS): Delete.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 3 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index e5a105f..edca6a9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -38,16 +38,13 @@ AM_CPPFLAGS = \
AM_CFLAGS = @GUILE_CFLAGS@
LDADD = @GUILE_LIBS@ src/libmcron.a
-bin_mcron_SOURCES = src/wrapper.c
-bin_mcron_CPPFLAGS = $(AM_CPPFLAGS) -DPROGRAM="\"mcron\""
+bin_mcron_SOURCES = src/mcron.c
bin_mcron_DEPENDENCIES = $(compiled_modules)
-bin_cron_SOURCES = src/wrapper.c
-bin_cron_CPPFLAGS = $(AM_CPPFLAGS) -DPROGRAM="\"cron\""
+bin_cron_SOURCES = src/cron.c
bin_cron_DEPENDENCIES = $(compiled_modules)
-bin_crontab_SOURCES = src/wrapper.c
-bin_crontab_CPPFLAGS = $(AM_CPPFLAGS) -DPROGRAM="\"crontab\""
+bin_crontab_SOURCES = src/crontab.c
bin_crontab_DEPENDENCIES = $(compiled_modules)
# wrapper to be used in the build environment and for running tests.