AboutSummaryRefsLogTreeCommitDiffStats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2020-05-08 17:19:28 +0200
committerMathieu Lirzin <mthl@gnu.org>2020-05-08 17:38:21 +0200
commitb0151cad38a7f71b5888f393db9b7d2673b67b52 (patch)
tree0cadb031352cb73adaa2108d6846d59b306c1e57 /Makefile.am
parent42fae5880eb53b48a2ea9bb4c8d07bbe23201ec9 (diff)
downloadmcron-b0151cad38a7f71b5888f393db9b7d2673b67b52.tar.gz
mcron-b0151cad38a7f71b5888f393db9b7d2673b67b52.tar.bz2
mcron-b0151cad38a7f71b5888f393db9b7d2673b67b52.zip
build: Handle missing "bin" directory
This fixes the generation of scripts when "bin" directory does not exist. * Makefile.am (bin/%): Invoke $(MKDIR_P) first.
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index e8fe80c..f63ff8f 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,6 @@
## Process this file with automake to produce Makefile.in.
# Copyright © 2003 Dale Mellor <dale_mellor@users.sourceforge.net>
-# Copyright © 2015, 2016, 2017, 2018 Mathieu Lirzin <mthl@gnu.org>
+# Copyright © 2015, 2016, 2017, 2018, 2020 Mathieu Lirzin <mthl@gnu.org>
#
# This file is part of GNU Mcron.
#
@@ -100,7 +100,8 @@ DISTCLEANFILES = src/mcron/config.scm
bin/% : src/%.in Makefile
- -@sed -e 's,%PREFIX%,${prefix},g' \
+ $(AM_V_GEN)$(MKDIR_P) bin ; \
+ sed -e 's,%PREFIX%,${prefix},g' \
-e 's,%modsrcdir%,${guilesitedir},g' \
-e 's,%modbuilddir%,${guilesitegodir},g' \
-e 's,%localstatedir%,${localstatedir},g' \
@@ -112,8 +113,8 @@ bin/% : src/%.in Makefile
-e 's,%PACKAGE_NAME%,@PACKAGE_NAME@,g' \
-e 's,%PACKAGE_URL%,@PACKAGE_URL@,g' \
-e 's,%GUILE%,$(GUILE),g' \
- $< > $@;
- -@chmod a+x $@
+ $< > $@ ; \
+ chmod a+x $@
## ------------ ##