AboutSummaryRefsLogTreeCommitDiffStats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2017-04-24 21:28:09 +0200
committerMathieu Lirzin <mthl@gnu.org>2017-09-28 15:50:58 +0200
commit9b52c0d4544b2ed0fba156f87b75632c75b2084c (patch)
tree37e69b94467a2ddef99b12fb126461920a8e9bf1 /Makefile.am
parent2b9828f303defc09cafa9f070d3583b4f1ac3107 (diff)
downloadmcron-9b52c0d4544b2ed0fba156f87b75632c75b2084c.tar.gz
mcron-9b52c0d4544b2ed0fba156f87b75632c75b2084c.tar.bz2
mcron-9b52c0d4544b2ed0fba156f87b75632c75b2084c.zip
wrapper: Move 'wrap_env_path' to a new 'utils' module.
* src/wrapper.c: Move 'wrap_env_path' to ... * src/utils.h: ... here. New module. * src/utils.c: New file. * configure.ac: Use AC_PROG_RANLIB and AM_PROG_AR. * Makefile.am (noinst_LIBRARIES, src_libmcron_a_SOURCES): New variables. (LDADD): Add 'src/libmcron.a'.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 7602341..e5a105f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -36,7 +36,7 @@ AM_CPPFLAGS = \
-D_GNU_SOURCE
AM_CFLAGS = @GUILE_CFLAGS@
-LDADD = @GUILE_LIBS@
+LDADD = @GUILE_LIBS@ src/libmcron.a
bin_mcron_SOURCES = src/wrapper.c
bin_mcron_CPPFLAGS = $(AM_CPPFLAGS) -DPROGRAM="\"mcron\""
@@ -53,6 +53,12 @@ bin_crontab_DEPENDENCIES = $(compiled_modules)
# wrapper to be used in the build environment and for running tests.
noinst_SCRIPTS = pre-inst-env
+# local library.
+noinst_LIBRARIES = src/libmcron.a
+src_libmcron_a_SOURCES = \
+ src/utils.c \
+ src/utils.h
+
## --------------- ##
## Guile modules. ##
## --------------- ##