AboutSummaryRefsLogTreeCommitDiffStats
path: root/configure.ac
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2017-02-23 02:01:08 +0100
committerMathieu Lirzin <mthl@gnu.org>2017-09-28 15:43:21 +0200
commit2b9828f303defc09cafa9f070d3583b4f1ac3107 (patch)
tree19f2bbd6c8d6c8ee8fe3961b9bbd00844dc4bbd5 /configure.ac
parent02d67e7f0ec67708f9c96466c63aacf921c6577f (diff)
downloadmcron-2b9828f303defc09cafa9f070d3583b4f1ac3107.tar.gz
mcron-2b9828f303defc09cafa9f070d3583b4f1ac3107.tar.bz2
mcron-2b9828f303defc09cafa9f070d3583b4f1ac3107.zip
build: Remove "--enable-debug" configure option
Unlike C code where debugging impose the "-g" compilation flags. This debugging option only affects Guile code, so using an environment variable works better since it doesn't impose to recompile Mcron or to edit "config.scm". * configure.ac: Remove "--enable-debug" configure option. * src/mcron/config.scm.in (config-debug): Use MCRON_DEBUG environment variable to trigger the debug mode at runtime.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 0 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index e7ff80c..c818dba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -29,20 +29,6 @@ AC_REQUIRE_AUX_FILE([git-version-gen])
AM_INIT_AUTOMAKE([subdir-objects -Wall -Wno-override])
AM_SILENT_RULES([yes]) # enables silent rules by default
-AC_MSG_CHECKING([whether debugging is requested])
-AC_ARG_ENABLE(debug,
- AC_HELP_STRING([--enable-debug],
- [enable debugging and traceback on error]),
- CONFIG_DEBUG=$enableval,
- CONFIG_DEBUG=no)
-AC_MSG_RESULT($CONFIG_DEBUG)
-if test "$CONFIG_DEBUG" = "no"; then
- CONFIG_DEBUG="#f"
-else
- CONFIG_DEBUG="#t"
-fi
-AC_SUBST(CONFIG_DEBUG)
-
AC_CANONICAL_HOST
AC_PROG_AWK
AC_PROG_EGREP